It is currently Tue Nov 21, 2017 1:26 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 107 posts ]  Go to page Previous  1 ... 4, 5, 6, 7, 8
Author Message
 Post subject: Re: 3DSimED 3.1i
PostPosted: Mon Jul 24, 2017 4:25 pm 
Offline
Tirechanger
Tirechanger

Joined: Tue Oct 04, 2016 3:44 pm
Posts: 16
Tomatosauce288 wrote:
ok most of these hood badge bugs are just texture bugs i guess: https://puu.sh/wS3nF/749525ac33.png

It seems the badges use a special shader and the associated textures look a bit funky as a result - I'm still trying to figure out the details relating to badge rendering, but here are my notes so far on the subject. If anyone has better info feel free to correct me:

In the diffuse badge textures, the usual RGB channels are used but the alpha channel appears to be metallic (no smoothness/specular data at all as far as I can tell or they are blended)
Wherever the alpha/metallic channel is 100% the artists seem to have a convention of painting the equivalent RGB pixels black, so the result is anything that appears black on the badge should render as chrome. The Pininfarina badges on the Maserati A6GCS are an example of this type of badge texture.

There are also badges that have no diffuse texture at all because they don't require more than one color. For these it appears the badges use the "_glos" texture which has no alpha channel and RGB channels are used together in a grayscale mode to define metallic % where white pixels are replaced with whatever albedo/diffuse color is assigned by the shader, and black pixels represent fully metallic/chrome areas. For example on the '95 Cobra R "snake" fender badges the black pixels become chrome and the white pixels become black, but only because black is the diffuse color that the shader will assign to this material.


Top
 Profile  
 
 Post subject: Re: 3DSimED 3.1i
PostPosted: Tue Oct 03, 2017 9:12 pm 
Offline
Jackman
Jackman

Joined: Wed Dec 07, 2016 8:41 pm
Posts: 2
I am not certain but I think when exporting rfactor 2 objects that it randomly moves the objects around. Not every object but just random ones.
I opened a previous version of the track and replaced a few objects, saved GMTS and Textures and some objects are moved (not the ones I replaced).

I did have to move the new objects so maybe that had some effect.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 107 posts ]  Go to page Previous  1 ... 4, 5, 6, 7, 8

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group